チェックサムが一致しないエラーでWordPressが更新できない件

7月にWordpress4.8.1が発表されましたね。

 

なんとなく、性分としてアップデートは基本素早く対応する質なので、

今回もいつものとおりアップデートしたのですが、

今回は初めて見るエラーで更新できませんでした。

 

私もいくつかサイトを持っているのですが、

他のブログは4.8.1でもちゃんと更新出来るので、

この備忘録ブログだけの現象でした。

 

エラーメッセージの内容

更新ボタンを押したときのエラーメッセージは、以下の通りでした。

 

https://downloads.wordpress.org/release/ja/wordpress-4.8.1.zip から更新をダウンロードしています…ダウンロードに失敗しました。: ファイルのチェックサム (…) が期待値 (…) と一致しません。

インストール失敗

 

いつもそのままアップデートしてしまうのですが、

プラグインを停止しても、何度再挑戦しても、

同上のエラーでした。

 

解決法はバックアップの削除

結局、原因は容量不足でした。

バックアップを同じサーバに取っているのですが、

過去の履歴分をいくつか削除したら、

正常に更新できるようになりました。

 

根本原因はバックアップ

を同一サーバに取りっぱなしにしていることなんですが…

クラウドサービスに取ることも考えねば、ですね。。。

 

ネットで調べても、

ちゃんとした解決策が載っていなかったので、

サーバ容量も一因としてチェックしてみてください。

 

以上、澄月でした。

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です